フォーミュラを駆る心理学者のブログ
  • 03«
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • »05
スポンサーサイト
--年--月--日 (--) | 編集 |
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。


rFactorをWindows7(32bit/64bit)でプレイするときのtips(さらに追記済み)
2010年11月17日 (水) | 編集 |
PCを新しくしました。

CPU:Core i7 870
Memory:DDR3 8GB
SSD:128GB
VGA:Radeon HD5850
OS:Windows7 64bit

何というか,ほぼ3年周期でだいたい新しくしてるなぁ・・・浪費癖だわ(^^;)

さておき,rFactorをWindows7(64bit)にインストールしたのですが,
その時に気づいたことをtipsとしてアップします。


・フォルダ構成について(Windwos7だけでなくVistaも?)

rF本体は通常の設定だと
 C:\Program Files (x86)\rFactor\
にインストールされますが,ここで正常に動作します。

ただ,ユーザーファイルなどの位置がXPと異なります。

設定ファイルやリプレイファイル,リザルトファイル(xml),MoTeCの記録ファイルなどは
 C:\Users\<<ユーザー名>>\AppData\Local\VirtualStore\Program Files (x86)\rFactor\
の中に作成されます。
エクスプローラーでは「Users」の部分は「ユーザー」と表示されます。

また,「AppData」というフォルダは隠しフォルダ属性になっているので,
「コントロールパネル」→「デスクトップのカスタマイズ」→「フォルダーオプション」→「表示」タブ→「隠しフォルダーを表示する」に設定変更しないと表示されません。

なお,MoTeCの解析ソフトは隠しフォルダに対応していないようで,
この設定変更をしてもAppDataフォルダが出てきませんでした。
隠しフォルダ設定を解除してもおそらく支障はないでしょうから,解除しちゃいました。
(支障=自分が誤って消してしまう。そんなことしませんww)

旧PCからユーザー設定のPLRファイルやcontroller.iniをコピーしたところ,
このフォルダ構成の違いのためか,rFが正常に起動しなくなってしまったので,
テキスト比較ソフトを使って必要な箇所のみをコピーしました。

<追記>

UACを切ると,XPと同じ位置にユーザーファイルが作成されるようです。(Ahoさんthx!)
コントロールパネル→
ユーザーアカウントと家族のための安全設定→ユーザーアカウント→ユーザーアカウント制御設定の変更
設定を一番下に変更

スポッタープラグインの「config」はXPと同じ位置にユーザーファイルが作成されていることが
前提に作られているようなので,こちらの設定にしてみると良いのかもしれません。
ただ,セキュリティ的には弱くなりますけどね・・・。

<追記ここまで>

・・・・それ以外は特に何もないです(^^;)

あとはプラグイン系は.netフレームワークなどを別途インストールする必要があるものがあるとか
(これはWindows7に限らず,まっさらなOSから始めるときは一緒か),
当然ですがハンコンのドライバーはそのOSに対応したものが必要だとか,
まあそんなもんですね。


余談ですが次のようなことも。

・MODインストール支援ツールが便利すぎる。

「Generic Mod Enabler」というものを使ってみました。
今まではいろいろいじくり回した後に,この存在を知ったので結局活用できませんでした。

詳しい説明はこちら。
MODの組み込み削除、思いのまま ー Generic Mod Enabler ー


とりあえず以上。

ご参考まで(=`ェ´=)にゃー
コメント
この記事へのコメント
管理人のみ閲覧できます
このコメントは管理人のみ閲覧できます
2010/12/24(金) 23:07:18 | | #[ 編集]
Re: .勝手にリンクしました
ども,こんにちは。

ブログ開設乙です!
さっそく,こちらからもリンクしましたm(_ _)m

そういえば,そろそろ広告追い出し記事かかないとなぁ(^^;)

(=`ェ´=)にゃー
2010/12/25(土) 08:55:50 | URL | 黒猫山登 #-[ 編集]
いろいろ巡ってここに辿り着きました。r-factorを買ったのですが、インストールしていざゲームを始めると車を選ぶとこまでは行くんですが、コースにでようとすると落ちてしまいます。何度やっても。それで一度アンインストールして再度インストールしようとすると、まったく起動しなくなり、それどころかディスクさえ読み込まなくなりました。宜しければ対処方法など教えて頂けないでしょうか?

ゲームはパッケージ版でWindows7のi5です。
2012/06/06(水) 17:04:36 | URL | アラン #-[ 編集]
Re: タイトルなし
>アランさん

こんな更新頻度の少ないブログに,ようこそ・・・(^^;)
私は既にrFactorのアクティブなユーザーではなくなってしまったので,ほとんど何も答えられないのですが・・・。


> r-factorを買ったのですが、インストールしていざゲームを始めると車を選ぶとこまでは行くんですが、コースにでようとすると落ちてしまいます。何度やっても。それで一度アンインストールして再度インストールしようとすると、まったく起動しなくなり、それどころかディスクさえ読み込まなくなりました。宜しければ対処方法など教えて頂けないでしょうか?
> ゲームはパッケージ版でWindows7のi5です。


これだけの情報では,なんとも言えないですね・・・。
(もっとも,私も専門家ではないので,他にどのような情報があったら原因が分かるのか不明ですが)


「全く起動しなくなった」という事は,現時点でrFactorそのものが正常にインストールされていないと思います。
一度(もう一度),アンインストールをして,インストールフォルダ(CのProgram Files(x86)など)に
残ったファイルも全て消してみてからもう一度インストールしてみてください。

ファイルが残っていると再インストール後も不具合を起こす可能性が高いです。

再インストール後に正常に起動するようになったら,
ひとまずMODなどを全く入れずに標準のファイルだけで動作できるか確かめてみてください。

くろねこ。(=`ェ´=)にゃー
2012/06/12(火) 09:01:10 | URL | 黒猫山登 #-[ 編集]
コメントを投稿する
URL:
Comment:
Pass:
秘密: 管理者にだけ表示を許可する
 
トラックバック
この記事のトラックバックURL
この記事へのトラックバック
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。